+7 (495) 797-3311
Узнать цену
Компания Решения Продукция
Сервис Новости Где купить

Узнать цену
ФИО *
E-mail *
Телефон *
Компания
Оборудование
* - поля, обязательные для заполнения
Отправить
QTECH - Quality Technology
Ethernet коммутаторы
Интеллектуальные решения
Оптические модули
Оборудование PON
Оборудование TDM
Мультимедиа
Транспортные сети передачи данных
Оборудование VoIP
Системы питания и контроля
Мобильные устройства и аксессуары
Пассивное телекоммуникационное оборудование
Абонентское оборудование
Беспроводные системы связи
Системы видеонаблюдения
Системы безопасности
Архив оборудования
 
РЕШЕНИЯ
ЗАЯВКА НА ТЕСТИРОВАНИЕ
СЕРТИФИКАТЫ
ВОПРОСЫ И ОТВЕТЫ
ПУБЛИКАЦИИ


 

Настройка RSTP на коммутаторах QTECH

02.07.2010, Сайт "Настройка активного оборудования различных вендоров", biparasite.ru

Cоберем тестовый стенд из одного QSW-3900, который будет root в дереве, от него в кольце  QSW-2900 и D-link DES-3526.

Вот что получилось:

Итак, приступим к настройке оборудования.

В первую очередь настроим QSW-3900

Создадим vlan, пусть это будет vlan 2001

QTECH_3900> en
QTECH_3900# conf t
QTECH_3900(config)# vlan 2001
QTECH_3900(config-if-vlan)# exit
QTECH_3900(config)# interface range ethernet 0/0/1 to ethernet 0/0/2
QTECH_3900(config-if-range)# switchport mode trunk
QTECH_3900(config-if-range)# switchport trunk allowed vlan 2001
QTECH_3900(config-if-range)# switchport trunk native vlan 2001
QTECH_3900(config-if-range)# exit

Теперь уберем vlan 1 с ethernet 0/0/1 и ethernet 0/0/2

QTECH_3900(config)# vlan 1
QTECH_3900(config-if-vlan)# no switchport ethernet 0/0/1 to ethernet 0/0/2
QTECH_3900(config-if-vlan)# exit

Создаем ip интерфейс

QTECH_3900(config)# interface vlan-interface 2001
QTECH_3900(config-if-vlanInterface-2001)# ip address 10.0.0.1 ?
A.B.C.D  ip address mask with A.B.C.D
QTECH_3900(config-if-vlanInterface-2001)# ip address 10.0.0.1 255.255.255.0 ?
<enter>  The command end.
QTECH_3900(config-if-vlanInterface-2001)# ip address 10.0.0.1 255.255.255.0
QTECH_3900(config-if-vlanInterface-2001)# exit

Смотрим, что у нас получилось

QTECH_3900(config)#sh ip interface

Включаем и настраиваем RSTP

QTECH_3900(config)# spanning-tree mode rstp
QTECH_3900(config)# spanning-tree priority 16384

Вот что получилось:

QTECH_3900(config)# sh spanning-tree interface

The bridge is executing the IEEE Rapid Spanning Tree protocol
The bridge has priority 16384, MAC address: 001f.ce10.1249
Configured Hello Time 2 second(s), Max Age 20 second(s),
Forward Delay 15 second(s)
Root Bridge has priority 16384, MAC address 001f.ce10.1249
Path cost to root bridge is 0
Stp top change 2 times

Port 1 (Ethernet0/0/1) of bridge is Forwarding
Spanning tree protocol is enabled
The port is a DesignatedPort
Port path cost 20000
Port priority 128
root guard disabled and port is not in root-inconsistent state
Designated bridge has priority 16384, MAC address 001f.ce10.1249
The Port is an edge port
Connected to a point-to-point LAN segment
Maximum transmission limit is 3  BPDUs per hello time
Times: Hello Time 2 second(s), Max Age 20 second(s)
Forward Delay 15 second(s), Message Age 0
sent BPDU:     2082
TCN: 0, RST: 2082, Config BPDU: 0
received BPDU: 0
TCN: 0, RST: 0, Config BPDU: 0

Port 2 (Ethernet0/0/2) of bridge is Forwarding
Spanning tree protocol is enabled
The port is a DesignatedPort
Port path cost 20000
Port priority 128
root guard disabled and port is not in root-inconsistent state
Designated bridge has priority 16384, MAC address 001f.ce10.1249
The Port is an edge port
Connected to a point-to-point LAN segment
Maximum transmission limit is 3  BPDUs per hello time
Times: Hello Time 2 second(s), Max Age 20 second(s)
Forward Delay 15 second(s), Message Age 0
sent BPDU:     2082
TCN: 0, RST: 2082, Config BPDU: 0
received BPDU: 0
TCN: 0, RST: 0, Config BPDU: 0

RSTP по умолчанию включено на всех портах, так что нужно теперь в ручную отключать, там где не надо.

QTECH_3900(config)# interface ethernet 0/0/3
QTECH_3900(config-if-ethernet-0/0/3)# no spanning-tree
QTECH_3900(config-if-ethernet-0/0/3)# exit

Смотрим, что получилось:

QTECH_3900(config)#sh spanning-tree interface ethernet 0/0/3

The bridge is executing the IEEE Rapid Spanning Tree protocol
The bridge has priority 16384, MAC address: 001f.ce10.1249
Configured Hello Time 2 second(s), Max Age 20 second(s),
Forward Delay 15 second(s)
Root Bridge has priority 16384, MAC address 001f.ce10.1249
Path cost to root bridge is 0
Stp top change 2 times

Port 3 (Ethernet0/0/3) of bridge is DOWN
Spanning tree protocol is disabled

Пока с настройками QTECH QSW-3900 закончим. Приступаем к настройке Qtech QSW-2900 и D-Link des-3526

Настраиваем QTECH QSW-2900

Создаем vlan 2001

QTECH_2900(1)> en
QTECH_2900(1)# conf t
QTECH_2900(1)(config)# vlan 2001
QTECH_2900(1)(config-if-vlan)# exit
QTECH_2900(1)(config)# interface range ethernet 1/1 to ethernet 2/1
QTECH_2900(1)(config-if-range)# switchport mode trunk
QTECH_2900(1)(config-if-range)# switchport trunk allowed vlan 2001
QTECH_2900(1)(config-if-range)# switchport trunk native vlan 2001
QTECH_2900(1)(config-if-range)# exit

Убираем vlan 1 с магистральных интерфейсов, нечего ему там делать.

QTECH_2900(1)(config)# vlan 1

QTECH_2900(1)(config-if-vlan)# no switchport ethernet 1/1 to ethernet 2/1
QTECH_2900(1)(config-if-vlan)# exit

Смотрим, что получилось:

Создаем интерфейс:

QTECH_2900(1)(config)# ipaddress vlan 2001
QTECH_2900(1)(config)# ipaddress 10.0.0.2 255.255.255.0 ?
A.B.C.D  gataway address <enter>  The command end.
QTECH_2900(1)(config)# ipaddress 10.0.0.2 255.255.255.0 10.0.0.1

Проверяем

QTECH_2900(1)(config)# sh ip

Switch configuration
ip obtained      : MANUAL
ip address       : 10.0.0.2
netmask          : 255.255.255.0
gateway          : 10.0.0.1
ManageVLAN       : 1,2001
MAC address      : 00:1f:ce:10:30:58

Первый vlan мне не нужен, убираем

QTECH_2900(1)(config)# no ipaddress vlan 1

Смотрим

QTECH_2900(1)(config)# sh ip

Switch configuration
ip obtained      : MANUAL
ip address       : 10.0.0.2
netmask          : 255.255.255.0
gateway          : 10.0.0.1
ManageVLAN       : 2001
MAC address      : 00:1f:ce:10:30:58

пробуем пинговать шлюз:

QTECH_2900(1)(config)#ping 10.0.0.1
PING 10.0.0.1: with 32 bytes of data:
Request timed out.
no answer from 10.0.0.1
Control-C
QTECH_2900(1)(config)#

Нет ответа, странно,  попробывал выставить скорость в ручную на интерфейсах

QTECH_2900(1)(config-if-range)# interface range ethernet 1/1 to ethernet 2/1
QTECH_2900(1)(config-if-range)# speed 1000
QTECH_2900(1)(config-if-range)# exit

QTECH_2900(1)(config)#ping 10.0.0.1

PING 10.0.0.1: with 32 bytes of data:

reply from 10.0.0.1: bytes=32 time<10ms TTL=64
reply from 10.0.0.1: bytes=32 time<10ms TTL=64

—-10.0.0.1 PING Statistics—-
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0/0/0
Control-C

Все работает.

Переходим к настройке RSTP.

QTECH_2900(1)(config)# sh spanning-tree interface

Spanning tree protocol is disabled
The bridge has priority 32768, MAC address: 001f.ce10.3058
Configured Hello Time 2 second(s), Max Age 20 second(s),
Forward Delay 15 second(s)

Включаем RSTP

QTECH_2900(1)(config)# spanning-tree
QTECH_2900(1)(config)# spanning-tree mode rstp
QTECH_2900(1)(config)# sh spanning-tree interface

The bridge is executing the IEEE Rapid Spanning Tree protocol
The bridge has priority 32768, MAC address: 001f.ce10.3058
Configured Hello Time 2 second(s), Max Age 20 second(s),
Forward Delay 15 second(s)
Root Bridge has priority 16384, MAC address 001f.ce10.1249
Path cost to root bridge is 2000000
Stp top change 10 times

Включили, но зачем нам клиентские порты, принимающие участие в построении дерева? отключаем :

QTECH_2900(1)(config)# int range ethernet 0/1 to ethernet 0/24
QTECH_2900(1)(config-if-range)# no spanning-tree

Проверяем:

QTECH_2900(1)(config-if-range)# sh spanning-tree interface ethernet 0/1

The bridge is executing the IEEE Rapid Spanning Tree protocol
The bridge has priority 32768, MAC address: 001f.ce10.3058
Configured Hello Time 2 second(s), Max Age 20 second(s),
Forward Delay 15 second(s)
Root Bridge has priority 16384, MAC address 001f.ce10.1249
Path cost to root bridge is 2000000
Stp top change 10 times

Port e0/1 of bridge is DOWN
Spanning tree protocol is disabled

А на магистральных портах все должно быть включено

Приступаем к настройке D-link des3526

Создаем vlan 2001

DES-3526:admin# create vlan vlan2001 tag 2001
DES-3526:admin# config vlan vlan2001 add tagged 25-26

Удаляем vlan 1 с 25-26 порта

DES-3526:admin# config vlan default delete 25-26

Создаем интерфейс:

DES-3526:admin# config ipif System ipaddress 10.0.0.3/24 vlan vlan2001 state enable

Создаем маршрут по умолчанию

DES-3526:admin# create iproute default 10.0.0.1

Смотрим что получилось и проверяем работоспособность.

Теперь настраиваем RSTP на des-3526

DES-3526:admin# config stp version rstp
DES-3526:admin# config stp maxage 20 maxhops 20 forwarddelay 15 txholdcount 3 fbpdu enable
DES-3526:admin# config stp hellotime 2
DES-3526:admin# enable stp
DES-3526:admin# config stp ports 1-24 externalCost auto edge true p2p auto state disable
DES-3526:admin# config stp ports 1-24 fbpdu disable
DES-3526:admin# config stp ports 1-24 restricted_role true
DES-3526:admin# config stp ports 1-24 restricted_tcn true
DES-3526:admin# config stp mst_ports 1-26 instance_id 0 internalCost auto priority 128
DES-3526:admin# config stp ports 25-26 externalCost auto edge false p2p auto state enable
DES-3526:admin# config stp ports 25-26 fbpdu enable
DES-3526:admin# config stp ports 25-26 restricted_role false
DES-3526:admin# config stp ports 25-26 restricted_tcn false

Проверяем:

Вот вроде бы и все, RSTP работает. В планах протестировать option 82 и acl на QTECH QSW-2900, а на  QSW-3900 хочется протестировать BGP и OSPF.




Все обзоры
ПОДПИСКА НА НОВОСТИ
Подписавшись на рассылку новостей, Вы будете 4-5 раз в месяц получать профессиональные обзоры сетевого оборудования QTECH, практичные готовые решения для организации сетей связи, информацию о новинках и специальных акциях компании.