Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Настройка DHCP-relay на QSW-2850/3470/3500/3750(T)/4610/8200/8250

         DHCP Relay - функционал коммутатора , обеспечивающий пересылку широковещательных DHCP-пакетов от клиента к серверу, находящемуся в другом широковещательной домене. Использование DHCP-relay убирает необходимость обеспечения L2-связности каждой физической подсети с DHCP сервером. Устройство, настроенное как DHCP L3 Relay, перехватывает широковещательные DHCP-пакеты в клиентской VLAN, и пересылает их однонаправленной рассылкой на IP-адрес DHCP-сервера и аналогично ретранслирует обратно к клиентам ответы от DHCP-сервера.

         DHCP-L3-relay в коммутаторах серии QSW-2850, QSW-3470, QSW-3500, QSW-3750(T), QSW-4610, QSW-8200, QSW-8250 реализован в рамках функционала ip helper. В рамках функционала ip helper в ретранслируемые DHCP пакеты могут добавлять под-опции AgentCircuitID и Remoute ID для опции 82 (DHCP Relay Agent Information Option), в которой указан номер vlan, порт через который получен пакет и адрес сетевого устройства.
            Agent Circuit ID - в ASCII формате "vlanZ+EthernetY/0/X"
            Remoute ID – в HEX формате указывается mac коммутатора

         На коммутаторах данных серий возможно одновременное включение DHCP-relay, а также DHCP-snooping, однако запрещено одновременное включение DHCP Snooping Information Option и DHCP Relay Information Option. Обратите внимание, что для vlan которые не имеют L2-связности с DHCP-сервером (терминируются на устройстве со включённым DHCP-L3-relay) работа с option 82 осуществляется согласно настройкам DHCP-L3-relay.

         Коммутатор, выступающий в роли DHCP-L3-relay, должен иметь IP-маршрут до DHCP-сервера и DHCP-сервер должен иметь IP-маршруты до клиентских подсетей.

    Пример конфигурации DHCP-relay и DHCP-server на коммутаторах серий QSW-2850, QSW-3470, QSW-3500, QSW-3750(T), QSW-4610, QSW-8200, QSW-8250:

    Схема работы DHCP-relay

    Рис. 1 – Схема работы DHCP-relay

    Конфигурация DHCP-relay

    DHCP-relay(config)#service dhcp                                        - Включаем DHCP сервис
    DHCP-relay(config)#ip forward-protocol udp bootps                      - Включаем перенаправление DHCP-пакетов
    DHCP-relay(config)#ip dhcp relay information option                    - Включаем добавление Option 82 к DHCP-пакетам DHCP-relay(config)#vlan 200                                            - Создаем клиентский VLAN DHCP-relay(config-vlan200)#interface vlan 200 DHCP-relay(config-if-vlan200)#ip address 192.168.2.2 255.255.255.0     - Назначаем ip адрес на интерфейсе коммутатора для клиентского VLAN DHCP-relay(config-if-vlan200)#ip helper-address 192.168.1.3            - Указываем ip-адрес DHCP-сервера, на который необходимо ретранслировать DHCP-пакеты. DHCP-relay(config)#vlan 100                                            - Создаем VLAN до DHCP-сервера DHCP-relay(config-vlan100)#interface vlan 100 DHCP-relay(config-if-vlan100)#ip address 192.168.1.2 255.255.255.0    - Назначаем ip адрес из подсети DHCP-сервера DHCP-relay(config)#vlan 4000                                           - Создаем «мусорный VLAN» для блокирования не тегированного трафика DHCP-relay(config)#interface ethernet 1/0/1 DHCP-relay(config-if-ethernet1/0/1)#switchport mode trunk DHCP-relay(config-if-ethernet1/0/1)#switchport trunk allowed vlan 100 DHCP-relay(config-if-ethernet1/0/1)#switchport trunk native vlan 4000  - Блокируем не тегированный трафик с помощью неиспользуемого VLAN-а DHCP-relay(config)#interface ethernet 1/0/2 DHCP-relay(config-if-ethernet1/0/2)#switchport access vlan 200

    Конфигурация DHCP-server

    DHCP-server(config)#service dhcp
    DHCP-server(config)#ip dhcp pool 200                                        - Настраиваем пул адресов DHCP-сервера
    DHCP-server(dhcp-200-config)#network-address 192.168.2.0 255.255.255.0
    DHCP-server(dhcp-200-config)#exit
    DHCP-server(config)#ip dhcp excluded-address 192.168.2.2                    - Указываем адреса, которые не будут выдаваться сервером
    DHCP-server(config)#ip route 192.168.2.0/24 192.168.1.2                     - Задаем транзитный адрес к подсети DHCP клиентов.
    DHCP-server(config)#interface ethernet 1/0/1
    DHCP-server(config-if-ethernet1/0/1)#switchport mode trunk
    DHCP-server(config-if-ethernet1/0/1)#switchport trunk allowed vlan 100
    DHCP-server(config)#vlan 100
    DHCP-server(config-vlan100)#interface vlan 100
    DHCP-server(config-if-vlan100)#ip address 192.168.1.3 255.255.255.0
    Опциональные команды
    DHCP-relay(config)#ip dhcp relay information option ? 
      delimiter      Select delimiter in colon(':'), dot('.'), slash('/'), andspace(' ') 
      remote-id      User remote-id mode 
      self-defined   Self-defined option82 format 
      subscriber-id  User subscriber-id mode

    Команда настраивает формат и содержание под-опций 82 опции.

    123.png

    Рис. 2 - Опция 82 с настройками по умолчанию

    DHCP-relay(config)#ip dhcp relay share-vlan 200 sub-vlan 400-444,555

    Данная команда позволяет ретранслировать множество клиентских VLAN-ов через один интерфейс L3 (VLAN 200). Обратите внимание, что для ретрансляции трафика, полученного через trunk-порт, требуется дополнительно указать на порту номер share-vlan, VLAN-а в который будут перенаправляться DHCP-пакеты.

    12.png

    Рис. 3 – Схема работы ip dhcp relay share-vlan 200 sub-vlan 400



    Смотрите так же

    К списку