Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Маршрутизации IPv4 на коммутаторах Qtech на примере OSPF, BGP, redistribution, PBR.

    Маршрутизации на коммутаторах Qtech на примере OSPF, BGP, redistribution, PBR.

    1) OSPF(англ. Open Shortest Path First) — протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-state technology) и использующий для нахождения кратчайшего пути алгоритм Дейкстры.

    Протокол OSPF был разработан IETF в 1988 году. Последняя версия протокола представлена в RFC 2328 (1998 год). Протокол OSPF представляет собой протокол внутреннего шлюза (Interior Gateway Protocol — IGP). Протокол OSPF распространяет информацию о доступных маршрутах между маршрутизаторами одной автономной системы.

    OSPF имеет следующие преимущества:

    Высокая скорость сходимости по сравнению с дистанционно-векторными протоколами маршрутизации; Поддержка сетевых масок переменной длины (VLSM); Оптимальное использование пропускной способности с построением дерева кратчайших путей; Подробное описание протокола и команды для его настройки можно найти в RFC и мануалах к нашему оборудованию, например:

    https://tools.ietf.org/html/rfc2328

    ftp://ftp.qtech.ru/upload/Switch/Manual/QSW-6500/Configuration%20Guide/09_Routing%20Protocol.pdf

    Ниже рассмотрим настройки простого соседства и перераспределения маршрутов на примере коммутаторов QSW-8370 и 8300.

    Для простого соседства необходимо выполнить следующие команды:

    QSW-8370:

     Создаем интерфейс, в котором будет передача маршрутов: 
    Switch(config)#interface Vlan10
    Switch(Config-if-Vlan10)#ip address 10.10.10.30 255.255.255.0
    Switch(Config-if-Vlan10)#exit
     Включаем протокол, задаем идентификатор и указываем, какие сети будут передаваться 
    Switch(config)#router ospf
    Switch(config-router)#ospf router-id 3.3.3.3
    Switch(config-router)#network 3.3.3.0 0.0.0.255 area 0
    Switch(config-router)#network 10.10.10.0 0.0.0.255 area 0
    
    

    QSW-8300:

     Создаем интерфейс, в котором будет передача маршрутов: 
    Switch(config)#interface Vlan10
    Switch(Config-if-Vlan10)#ip address 10.10.10.20 255.255.255.0
    Switch(Config-if-Vlan10)#exit
     Включаем протокол, задаем идентификатор и указываем, какие сети будут передаваться 
    Switch(config)#router ospf
    Switch(config-router)#ospf router-id 2.2.2.2
    Switch(config-router)#network 2.2.2.0 0.0.0.255 area 0
    Switch(config-router)#network 10.10.10.0 0.0.0.255 area 0
    


    2) BGP (Border Gateway Protocol) — это основной протокол динамической маршрутизации, который используется в Интернете.

    Маршрутизаторы, использующие протокол BGP, обмениваются информацией о доступности сетей. Вместе с информацией о сетях передаются различные атрибуты этих сетей, с помощью которых BGP выбирает лучший маршрут, и настраиваются политики маршрутизации.

    Один из основных атрибутов, который передается с информацией о маршруте — это список автономных систем, через которые прошла эта информация. Эта информация позволяет BGP определять, где находится сеть относительно автономных систем, исключать петли маршрутизации, а также может быть использована при настройке политик.

    Маршрутизация осуществляется пошагово от одной автономной системы к другой. Все политики BGP настраиваются, в основном, по отношению к внешним/соседним автономным системам. То есть, описываются правила взаимодействия с ними.

    Подробное описание протокола и команды для его настройки можно найти в мануалах к нашему оборудованию, например:

    https://tools.ietf.org/html/rfc4271

    ftp://ftp.qtech.ru/upload/Switch/Manual/QSW-6500/Configuration%20Guide/09_Routing%20Protocol.pdf

    Ниже рассмотрим настройки простого соседства и на примере коммутаторов QSW-8370 и 8300.

    Для этого нам необходимо выполнить следующие команды:

    QSW-8370:

     Создаем интерфейс, в котором будет передача маршрутов: 
    Switch(config)#interface Vlan10
    Switch(Config-if-Vlan10)#ip address 10.10.10.30 255.255.255.0
     Включаем протокол с указанием AS, указываем, какие сети будут передаваться, а так же соседство с указанием их AS 
    Switch(config)#router bgp 200
    Switch(config-router)#network 30.0.0.0/8
    Switch(config-router)#neighbor 10.10.10.20 remote-as 100 
    

    QSW-8300:

     Создаем интерфейс, в котором будет передача маршрутов: 
    Switch(config)#interface Vlan10
    Switch(Config-if-Vlan10)#ip address 10.10.10.20 255.255.255.0
     Включаем протокол с указанием AS, указываем, какие сети будут передаваться, а так же соседство с указанием их AS 
    Switch(config)#router bgp 100
    Switch(config-router)#network 20.0.0.0/8
    Switch(config-router)#neighbor 10.10.10.30 remote-as 200 
    

    3) Пераспределение маршрутов.

    Применение протокола маршрутизации для объявления маршрутов, определяемых другими способами (например, другим протоколом маршрутизации, статическими маршрутами или маршрутами с прямым подключением), называется перераспределением.

    Для перераспределения маршрутов на коммутаторе необходимо настроить следующее:


     Создаем интерфейсы, в котором будет передача маршрутов: 
    Switch(config)#interface vlan 10
    Switch(Config-if-Vlan1)#ip address 1.1.1.1 255.255.255.0
    Switch(Config-if-Vlan1)#exit
    Switch(config)#interface vlan 20
    Switch(Config-if-Vlan2)#ip address 2.2.2.2 255.255.255.0
    Switch(Config-if-Vlan2)#exit
     Затем включим протокол маршрутизации и анонсируем сети: 
    Switch(config)#router ospf 10
    Switch(config-router)#network 2.2.2.0/24 area 1
    Switch(config-router)#exit
    Switch(config)#router ospf 20
    Switch(config-router)#network 1.1.1.0/24 area 1
     Здесь указываем, что перераспределяем процесс 10: 
    Switch(config-router)#redistribute ospf 10
    Switch(config-router)#exit 
    

    4) PBR

    Маршрутизация на основе политик (policy based routing, PBR) позволяет маршрутизировать трафик на основании заданных политик, тогда как в обычной маршрутизации, только IP-адрес получателя определяет каким образом будет передан пакет.

     Создаем ACL, в котором укажем нужные нам сети:' 
    ip access-list extended TEST1
    permit ip 10.34.0.0 0.0.255.255 1.1.1.0 0.0.0.255
    deny ip 10.34.0.0 0.0.255.255 any-destination
    exit
    ip access-list extended TEST2
    permit ip 10.34.0.0 0.0.255.255 any-destination
    exit
     Затем создаем классы в которых будем искать нужные пакеты с адресами в соответствие с ACL 
    class-map TEST1
    match access-group TEST1
    class-map TEST2
    match access-group TEST2
    
     На основании отобранных пакетов создаем политику, что с этими пакетами делать: 
    policy-map TEST
    class TEST1
    set ip nexthop 10.0.0.1 exit
    class TEST2
    set ip nexthop 10.19.7.4 
    exit
     Применяем политику на входящий трафик во влане: 
    service-policy input TEST vlan 100


    Смотрите так же
    Для данной линейки коммутаторов, если у вас появилась необходимость организовать динамически назначаемый Voice Vlan, вам необходимо Разрешить получение LLDP информации. Создать Voice vlan перевести порт в режим работы Trunk Проверить что на порту разрешено LLDP Указать Voice Vlan на пор...
    Vlan-translation VLAN-translation - это функция, которая позволяет преобразовать тэг VLAN пакета в новый в соответствии с требованиями. Это позволяет обмениваться данными в разных VLAN. VLAN-translation может быть использован на обоих направлениях трафика. Ниж...
    Виртуальное тестирование кабеля(VCT) на коммутаторах QSW-2850/3470/4610 Virtual Cable Tester. Функция коммутатора, благодаря которой можно провести виртуальный тест медного кабеля.  Для ввода команды, переходим в привилегированный режим. (enable ) Далее вводим команду:  ...

    К списку