Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Настройка QinQ Selective на коммутаторах QSW-2850/3470/4610.

    Для тестовой настройки воспользуемся коммутатором QSW-3470-52T-AC, но настройки будут аналогичны и для QSW-2850 и для QSW-4610. Версия ПО в эксперименте 8.2.1.104,

    ТЗ

    1. Vlan 5 забрать из Trunk и отдать в QinQ uplink в неизменном виде(одна метка Vlan5)
    2. Vlan 15 забрать из Trunk и отдать в QinQ uplink с дополнительным тегом 100(то есть Верхняя метка Vlan 100, за ней нижняя метка Vlan 15)
    3. Vlan’ны с 30 по 40 забрать из Trunk и отдать в QinQ uplink с дополнительным тегом 101 (то есть Верхняя метка Vlan 101, за ней нижняя метка Vlan в диапазоне с 30 по 40)

    Ниже схема которую нам необходимо собрать для тестового стенда.

    qinq-Страница 2.png


    Как видите, схема для проведения тестирования достаточно проста, а отслеживать результат мы будем непосредственно на QinQ uplink порту.

    В качестве коммутатора предоставляющего трафик в Trunk мы будем использовать коммутатор QSW-3470-28T-LPOE-AC. Его конфигурация крайне проста и выглядит следующим образом:

    no service password-encryption
    !
    hostname QSW-3470-28T-LPOE-AC
    sysLocation Russia, Moscow, Ryabinovaya st, 26 bld 2
    sysContact +7(495)797-3311
    !
    username admin privilege 15 password 0 admin
    !
    !
    !
    !
    !
    vlan 1;5;15;35 
    !
    Interface Ethernet1/0/1
    switchport access vlan 5

    Interface Ethernet1/0/2
    switchport access vlan 15
    !
    Interface Ethernet1/0/3
    switchport access vlan 35
    !
    Interface Ethernet1/0/4
    switchport mode trunk
    !
    Interface Ethernet1/0/5
    !
    —————-//—————-
    …..
    —————-//—————- 
    Interface Ethernet1/0/27
    !
    Interface Ethernet1/0/28
    !
    interface Vlan1
    !
    no login
    !
    end

    То есть мы настроили 3 Access порта для создания трафика в необходимых по нашему ТЗ Vlan и один порт в mode trunk для того что бы передать его в наш целевой QSW-3470-52T-AC

    Начинаем настройку целевого QSW-3470

    Для начала объявим все необходимые Vlan. Так как у меня тестовый коммутатор, я объявляю с запасом с 1 по 550

    QSW-3470-52T-AC(config)#vlan 1-550

    Затем,  необходимо в режиме глобальной конфигурации объявить необходимый размер MTU который будет пропускать наш коммутатор.

    По умолчанию данное число 1500 байт, и добавление 1го дополнительного тега потребовало бы от нас объявить MTU в 1504 байта. Но так как в данном случае принцип «больше, не меньше» работает прекрасно объявим сразу 9000.

    QSW-3470-52T-AC(config)#mtu 9000

    Далее переходим к непосредственно настройке QinQ.

    Для начала нам необходимо настроить порт в сторону отслеживающего результат ПК, то есть QinQ uplink.

    У нас на схеме это interface Ethernet1/0/2. И для данного коммутатора настройка до неприличия проста. Порт просто необходимо объявить как Trunk.


    QSW-3470-52T-AC(config)#interface ethernet 1/0/2
    QSW-3470-52T-AC(config-if-ethernet1/0/2)# switchport mode trunk


    И теперь настраиваем интерфейс принимающий целевой трафик с Trunk интерфейса(Interface Ethernet1/0/1)

    Тут нужно быть внимательным, для начала необходимо объявить режим работы интерфейса как гибридный и задать параметры Vlan руководствуясь следующими критериями

    1. Если на трафик будет навешиваться дополнительный тег, значит надо пометить Vlan данного тега как Untagged
    2. Если тегированный трафик не должен затрагиваться, и должен обработаться коммутатором как трафик обычного trunk то данный тег необходимо пометить как tagged

    Исходя из этих правил и нашего ТЗ необходимо объявить Vlan 100 и 101 как Untagged и Vlan 5 как tagged

    QSW-3470-52T-AC(config)#interface ethernet 1/0/1
    QSW-3470-52T-AC(config-if-ethernet1/0/1)#switchport mode hybrid 
    QSW-3470-52T-AC(config-if-ethernet1/0/1)#switchport hybrid allowed vlan 5 tag
    QSW-3470-52T-AC(config-if-ethernet1/0/1)#switchport hybrid allowed vlan 100-101 untag

    И после этого прописать правила обработки тегированных пакетов для навешивания второй метки.

    Включить режим работы «selective»

    QSW-3470-52T-AC(config-if-ethernet1/0/1)#dot1q-tunnel selective enable

    Прописать правила для навешивания второго тега по следующему шаблону

    #dot1q-tunnel selective s-vlan {внешний Vlan} c-vlan {внутренний Vlan}

    для нашего ТЗ данные правила будут выглядеть следующим образом

    QSW-3470-52T-AC(config-if-ethernet1/0/1)# dot1q-tunnel selective s-vlan 100 c-vlan 15
    QSW-3470-52T-AC(config-if-ethernet1/0/1)# dot1q-tunnel selective s-vlan 101 c-vlan 30-40

    Остается только показать полную конфигурацию QSW-3470 и проверить работоспособность относительно нашего ТЗ

    show running-config
    !
    no service password-encryption
    !
    hostname QSW-3470-52T-AC
    sysLocation Russia, Moscow, Ryabinovaya st, 26 bld 2
    sysContact +7(495)797-3311
    !
    username admin privilege 15 password 0 admin
    !
    !
    !
    !
    !
    !
    !
    !
    !
    mtu 9000
    !
    !
    vlan 1-550 
    !
    Interface Ethernet1/0/1
    dot1q-tunnel selective s-vlan 100 c-vlan 15
    dot1q-tunnel selective s-vlan 101 c-vlan 30-40
    dot1q-tunnel selective enable
    switchport mode hybrid
    switchport hybrid allowed vlan 5 tag
    switchport hybrid allowed vlan 100-101 untag
    !
    Interface Ethernet1/0/2
    switchport mode trunk
    !
    Interface Ethernet1/0/3
    !
    Interface Ethernet1/0/4
    !
    —————-//—————-
    …..
    —————-//—————-  
    !
    Interface Ethernet1/0/50
    !
    Interface Ethernet1/0/51
    !
    Interface Ethernet1/0/52
    !
    interface Vlan1
    ip dhcp-client enable
    !
    no login
    !
    end

    Для первого Пункта ТЗ вставляем ПК источник трафика в порт 1 нашего QSW-3470-28T-LPOE-AC и видим всего один тег Vlan 5.

    vlan5(QSW-3470).png

    Для второго Пункта ТЗ вставляем ПК источник трафика в порт 2 нашего QSW-3470-28T-LPOE-AC и видим уже 2 тега Vlan 100 и внутри него Vlan 15.

    vlan 15 100(QSW-3470).png
    Для третьего Пункта ТЗ вставляем ПК источник трафика в порт 3 нашего QSW-3470-28T-LPOE-AC и снова видим необходимые нам два тега Vlan 101 и в нем в Vlan 35.
    vlan 35 101(QSW-3470).png


    Смотрите так же
    Для данной линейки коммутаторов, если у вас появилась необходимость организовать динамически назначаемый Voice Vlan, вам необходимо Разрешить получение LLDP информации. Создать Voice vlan перевести порт в режим работы Trunk Проверить что на порту разрешено LLDP Указать Voice Vlan на пор...
    Vlan-translation VLAN-translation - это функция, которая позволяет преобразовать тэг VLAN пакета в новый в соответствии с требованиями. Это позволяет обмениваться данными в разных VLAN. VLAN-translation может быть использован на обоих направлениях трафика. Ниж...
    Виртуальное тестирование кабеля(VCT) на коммутаторах QSW-2850/3470/4610 Virtual Cable Tester. Функция коммутатора, благодаря которой можно провести виртуальный тест медного кабеля.  Для ввода команды, переходим в привилегированный режим. (enable ) Далее вводим команду:  ...

    К списку