Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Настройка WAN Failover на QSR-28xx

    Настройка WAN Failover на QSR-28xx маршрутизаторах


    Данная настройка необходима, когда стоит задача настроить маршрутизатор на работу с двумя интернет-провайдерами. Тогда один канал будет основным, а второй WAN можно использовать как для резервирования основного канала, так и для распределения нагрузки между обоими внешними каналами.

    За пример в настройках будут взяты два провайдера, которые выдали нам по статическому адресу. Для понимания принципа работы этого будет достаточно. При использовании DHCP, туннельных протоколов принцип не поменяется. 


    // Указываем в качестве серверов имен адреса DNS-серверов от обоих провайдеров, можно воспользоваться независимым публичным DNS-сервером, например 8.8.8.8
    !
    ip domain name-server address 192.168.77.1
    ip domain name-server address 192.168.55.1
    !

    !
    interface GigaEthernet0/0
    ip address 192.168.77.10 255.255.255.0 //WAN адрес от провайдера 1
    no ip directed-broadcast
    ip-keepalive address 8.8.8.8 192.168.77.1 //проверяем на доступность внешний ресурс (8.8.8.8) через шлюз провайдера 1
    ip-keepalive period 2 //интервал проверки выставлен в 2 сек, для минимального простоя
    ip nat outside
    ip http firewalltype 0
    !
    interface GigaEthernet0/1
    ip address 192.168.55.10 255.255.255.0 //WAN адрес от провайдера 2
    no ip directed-broadcast
    ip-keepalive address 8.8.8.8 192.168.55.1 //проверяем на доступность внешний ресурс через шлюз провайдера 2
    ip-keepalive period 2
    ip nat outside
    ip http firewalltype 0
    !


    !
    interface GigaEthernet0/5
    ip address 192.168.2.1 255.255.255.0 // сеть LAN
    no ip directed-broadcast
    ip nat inside
    ip http firewalltype 0
    !

    !
    ip route default 192.168.55.1 // основной маршрут
    ip route default 192.168.77.1 // резервный. Оба маршрута с одинаковым приоритетом
    !

    //Список доступа (access list) для NAT. Разрешаем всю сеть.

    !
    ip access-list extended NAT_WAN0_LIST
    permit ip 192.168.2.0 255.255.255.0 any sequence 10
    !
    ip access-list extended NAT_WAN1_LIST
    permit ip 192.168.2.0 255.255.255.0 any sequence 10


    //Настройки DHCP-сервера на маршрутизаторе. В качестве DNS-сервера, который будут использовать пользователи нашей сети при получении настроек IP по протоколу DHCP, в нашем примере настроим LAN интерфейс маршрутизатора. В качестве DNS-сервера также может выступать независимый от провайдера сервер, либо по одному DNS-серверу от каждого провайдера, чтобы при любом активном канале у клиента был хотя бы один рабочий сервер имен.

    !
    ip dhcpd pool dpool
    network 192.168.2.0 255.255.255.0
    range 192.168.2.10 192.168.2.255
    default-router 192.168.2.1 
    dns-server 192.168.2.1 
    lease infinite 
    !

    //правила NAT
    !
    ip nat inside source list NAT_WAN0_LIST interface GigaEthernet0/0
    ip nat inside source list NAT_WAN1_LIST interface GigaEthernet0/1
    !


    Смотрите так же

    К списку