Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Настройка приоритизации трафика на коммутаторах доступа через vlan.

    Настройка приоритизации трафика на коммутаторах доступа через vlan.

    Допустим, стоит задача настроить приоритет c помощью qos для различного типа трафика (IPTV, VOIP и др.). Известно, что трафик передается через следующие vlan`ы:
    10 vlan – IPTV (должен иметь наивысший приоритет)
    20 vlan – VOIP (должен иметь наименьший приоритет)
    30 vlan – весь остальной трафик (должен иметь средний приоритет).
    Приоритизацию необходимо настроить на исходящий трафик портов 1, 2 и на входящий трафик портов 1, 4.

    I. Порядок настройки приоритизации на QSW-2800, QSW-2850, QSW-3000, QSW-3400, QSW-3450, QSW-3470, QSW-3580, QSW-8200, QSW-8370, QSW-8400, QSW-4610

    1. Создать для каждого vlan свой класс:
    (config)#class-map IPTV
    (config-classmap-test1)#match vlan 10
    (config-classmap-test1)#exit

    2. Создать политику «policy-map»
    (config)#policy-map TEST

    3. Задать для каждого vlan приоритет
    3.1. С помощью QOS
    (config-policymap-test)#class IPTV
    (config-policymap-test-class-test1)#set cos 3
    (config-policymap-test-class-test1)#exit
    Чем выше значение параметра “cos”, тем выше приоритет
    3.2. С помощью DSCP
    (config-policymap-test)#class IPTV
    (config-policymap-test-class-test1)#set ip dscp 30
    (config-policymap-test-class-test1)#exit
    Чем выше значение параметра “dscp”, тем выше приоритет
    4. Применить политику на нужных портах и в нужном направлении.
    (config-if-ethernet1/2)#service-policy input TEST
    (config-if-ethernet1/2)#service-policy output TEST

    Общий вид конфигурации для поставленной задачи выглядит следующим образом:
    #config
    (config)#class-map IPTV
    (config-classmap-test1)#match vlan 10
    (config-classmap-test1)#exit
    (config)#class-map VOIP
    (config-classmap-test2)#match vlan 20
    (config-classmap-test2)#exit
    (config)#class-map simple_traffic
    (config-classmap-test2)#match vlan 30
    (config-classmap-test2)#exit
    (config)#policy-map TEST
    (config-policymap-test)#class IPTV
    (config-policymap-test-class-test1)#set cos 3
    (config-policymap-test-class-test1)#exit
    (config-policymap-test)#class simple_traffic
    (config-policymap-test-class-test2)#set cos 2
    (config-policymap-test-class-test1)#exit
    (config-policymap-test)#class VOIP
    (config-policymap-test-class-test2)#set cos 1
    (config-policymap-test-class-test1)#exit
    (config-policymap-test)#exit
    (config)#interface ethernet 1/1
    (config-if-ethernet1/1)#service-policy input TEST
    (config-if-ethernet1/1)#service-policy output TEST
    (config-if-ethernet1/1)#exit
    (config)#interface ethernet 1/2
    (config-if-ethernet1/2)#service-policy output TEST
    (config-if-ethernet1/2)#exit
    (config)#interface ethernet 1/4
    (config-if-ethernet1/4)#service-policy input TEST
    (config-if-ethernet1/4)#exit

    II. Порядок настройки приоритизации на QSW-2910

    1. Создать ACL:
    (config)#access-list link IPTV
    2. Создание правила для трафика:
    (config-link-nacl-iptv)#permit ingress 10 interface ethernet 0/0/5 egress interface ethernet 0/0/6.
    Это правило можно разъяснить следующим образом:
    «Выделить» весь трафик, который приходит с vlan 10 c интерфейса interface ethernet 0/0/5 в интерфейс interface ethernet 0/0/6.
    3. Задание приоритета для трафика, который попал под данное правило
    3.1 C помощью qos:
    (config)#traffic-priority link-group IPTV cos 3
    3.2 С помощью dscp
    (config)#traffic-priority link-group IPTV dscp 30
    Общий вид конфигурации для поставленной задачи выглядит следующим образом:
    (config)#access-list link IPTV
    (config-link-nacl-iptv)#permit ingress 10 interface ethernet 0/0/1 egress any
    (config-link-nacl-iptv)#permit ingress 10 egress interface ethernet 0/0/1.
    (config-link-nacl-iptv)#permit ingress 10 egress interface ethernet 0/0/2.
    (config-link-nacl-iptv)#permit ingress 10 interface ethernet 0/0/4 egress any
    (config-link-nacl-iptv)#exit
    (config)#access-list link simple_traffic
    (config-link-nacl-simple_traffic)#permit ingress 30 interface ethernet 0/0/1 egress any
    (config-link-nacl-simple_traffic)#permit ingress 30 egress interface ethernet 0/0/1.
    (config-link-nacl-simple_traffic)#permit ingress 30 egress interface ethernet 0/0/2.
    (config-link-nacl-simple_traffic)#permit ingress 30 interface ethernet 0/0/4 egress any
    (config-link-nacl-simple_traffic)#exit
    (config)#access-list link VOIP
    (config-link-nacl-voip)#permit ingress 20 interface ethernet 0/0/1 egress any
    (config-link-nacl-voip)#permit ingress 20 egress interface ethernet 0/0/1.
    (config-link-nacl-voip)#permit ingress 20 egress interface ethernet 0/0/2.
    (config-link-nacl-voip)#permit ingress 20 interface ethernet 0/0/4 egress any
    (config-link-nacl-voip)#exit
    (config)#traffic-priority link-group IPTV cos 3
    (config)#traffic-priority link-group simple_traffic cos 2
    (config)#traffic-priority link-group VOIP cos 1


    Смотрите так же
    Для данной линейки коммутаторов, если у вас появилась необходимость организовать динамически назначаемый Voice Vlan, вам необходимо Разрешить получение LLDP информации. Создать Voice vlan перевести порт в режим работы Trunk Проверить что на порту разрешено LLDP Указать Voice Vlan на пор...
    Vlan-translation VLAN-translation - это функция, которая позволяет преобразовать тэг VLAN пакета в новый в соответствии с требованиями. Это позволяет обмениваться данными в разных VLAN. VLAN-translation может быть использован на обоих направлениях трафика. Ниж...
    Виртуальное тестирование кабеля(VCT) на коммутаторах QSW-2850/3470/4610 Virtual Cable Tester. Функция коммутатора, благодаря которой можно провести виртуальный тест медного кабеля.  Для ввода команды, переходим в привилегированный режим. (enable ) Далее вводим команду:  ...

    К списку