Отправить запрос

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Настройки QinQ selective QSW-8330/QSW-4000

    Имеем в распоряжении коммутатор Qtech QSW-4000, но настройки аналогичны и для коммутаторов QSW-8330

    На коммутаторе будет использоваться ПО версии 64746(внимание на ПО более ранних версий, QinQ не работает на портах LACP)

    Так же нам потребуется коммутатор, который будет предоставлять Trunk c трафиком в Vlan 5, 15, 35

    Задача состоит в следующем

    Vlan 5 забрать из Trunk и отдать в QinQ uplink в неизменном виде(одна метка Vlan5)
    Vlan 15 забрать из Trunk и отдать в QinQ uplink с дополнительным тегом 100(то есть Верхняя метка Vlan 100, за ней нижняя метка Vlan 15)
    Vlan’ны с 30 по 40 забрать из Trunk и отдать в QinQ uplink с дополнительным тегом 101 (то есть Верхняя метка Vlan 101, за ней нижняя метка Vlan в диапазоне с 30 по 40)

    Ниже схема которую нам необходимо собрать для тестового стенда
    QinQ-8330.png

    Как видите, схема для проведения тестирования достаточно проста, а отслеживать результат мы будем непосредственно на QinQ uplink порту.

    В качестве коммутатора предоставляющего трафик в Trunk мы будем использовать коммутатор QSW-3470-28T-LPOE-AC

    Его конфигурация

    no service password-encryption
    !
    hostname QSW-3470-28T-LPOE-AC
    sysLocation Russia, Moscow, Ryabinovaya st, 26 bld 2
    sysContact +7(495)797-3311
    !
    username admin privilege 15 password 0 admin
    !
    !
    !
    !
    !
    vlan 1;5;15;35
    !
    Interface Ethernet1/0/1
    switchport access vlan 5
    !
    Interface Ethernet1/0/2
    switchport access vlan 15
    !
    Interface Ethernet1/0/3
    switchport access vlan 35
    !
    Interface Ethernet1/0/4
    switchport mode trunk
    !
    Interface Ethernet1/0/5
    !
    —————-//—————-
    …..
    —————-//—————-
    Interface Ethernet1/0/27
    !
    Interface Ethernet1/0/28
    !
    interface Vlan1
    !
    no login
    !
    end

    То есть мы выделили 3 порта для источников трафика в mode access и один порт в mode trunk для того что бы передать его в наш QSW-4000

    теперь начнем настройку QSW-4000

    для начала необходимо объявить все необходимые Vlan и включить обработку QinQ. Я объявляю с запасом с 1 по 500

    Switch#conf
    Switch_config#dot1q-tunnel
    Switch_config#vlan 1-500
    Creating VLAN(s),please wait…
    OK!
    Switch_config#


    Теперь необходимо настроить QinQ Uplink порт, он у нас на схеме выше находится за GigaEthernet0/3

    Switch_config#interface GigaEthernet0/3
    Switch_config_g0/3#switchport mode dot1q-tunnel-uplink

    Теперь нам остается настроить правила на интерфейсе принимающем трафик с Trunk(GigaEthernet0/4) 

    Switch_config#interface GigaEthernet0/4
    Switch_config_g0/4#switchport mode dot1q-translating-tunnel
    Switch_config_g0/4#switchport dot1q-translating-tunnel mode QinQ translate 15 100 1
    Switch_config_g0/4#switchport dot1q-translating-tunnel mode QinQ translate 30-40 101 1

    Как видим задается режим работы dot1q-translating-tunnel, аналог Access или Trunk только несущий дополнительный набор функций. И после того как режим порта задан, прописываем правила на какой трафик какие дополнительные метки вешать.

    Таким образом один Vlan носитель может внутри себя переносить десятки клиентских Vlan что расширяет возможности сети.

    Но частой ошибкой при настройке QinQ является то, что забывают установить MTU. А ведь если на оригинальный пакет добавить дополнительную информацию, значит необходимо что бы коммутаторы обрабатывали данный Frame а не отбрасывали как «неправильный»

    Соответственно, финальным штрихом для завершения настройки QinQ является увеличение размера обрабатываемого пакета по всему маршруту следования в сети.

    В нашем случае это делается исключительно на нашем QSW-4000, и разрешим сразу размер в 5000 байт

    Switch_config#interface GigaEthernet0/4
    Switch_config_g0/4#switchport mtu 5000
    set mtu successfully!
    Switch_config_g0/4#interface GigaEthernet0/3
    Switch_config_g0/3#switchport mtu 5000
    set mtu successfully!

    И того, нам осталось увидеть полную конфигурацию QSW-4000 и проверить работоспособность настройки относительно нашего изначального ТЗ

    show running-config
    Building configuration…
    Current configuration:
    !
    !version 2.2.0C build 64746
    service timestamps log date
    service timestamps debug date
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode rstp
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    aaa authentication login default local
    aaa authentication enable default none
    aaa authorization exec default local
    !
    username admin password 0 admin
    !
    !
    !
    !
    !
    !
    !
    interface Null0
    !
    interface GigaEthernet0/1
    !
    interface GigaEthernet0/2
    !
    interface GigaEthernet0/3
    switchport mode dot1q-tunnel-uplink
    switchport mtu 5000
    !
    interface GigaEthernet0/4
    switchport mode dot1q-translating-tunnel
    switchport dot1q-translating-tunnel mode QinQ translate 15 100 1
    switchport dot1q-translating-tunnel mode QinQ translate 30-40 101 1
    switchport mtu 5000
    !
    interface GigaEthernet0/5
    !
    interface GigaEthernet0/6
    !
    interface GigaEthernet0/7
    !
    interface GigaEthernet0/8
    !
    interface TGigaEthernet1/1
    !
    interface TGigaEthernet1/2
    !
    interface TGigaEthernet1/3
    !
    interface TGigaEthernet1/4
    !
    interface TGigaEthernet1/5
    !
    interface TGigaEthernet1/6
    !
    interface TGigaEthernet1/7
    !
    interface TGigaEthernet1/8
    !
    interface TGigaEthernet1/9
    !
    interface TGigaEthernet1/10
    !
    interface TGigaEthernet1/11
    !
    interface TGigaEthernet1/12
    !
    interface VLAN1
    ip address 192.168.0.1 255.255.0.0
    no ip directed-broadcast
    !
    !
    !
    dot1q-tunnel
    vlan 1-500
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip exf
    !
    ipv6 exf
    !
    !
    !
    !
    !
    ip http server
    !
    !
    !
    !
    !
    !
    !
    !Pending configurations for absent linecards:
    !
    !No configurations pending global

    И проверяем работоспособность. Отслеживая трафик при помощи Wireshark

    Для первого Пункта ТЗ вставляем ПК источник трафика в порт 1 нашего QSW-3470-28T-LPOE-AC и видим всего один тег Vlan 5.

    vlan5-1024x669.png

    Для второго Пункта ТЗ вставляем ПК источник трафика в порт 2 нашего QSW-3470-28T-LPOE-AC и видим уже 2 тега Vlan 100 и внутри него Vlan 15.

    vlan-15-100-1024x669.png

    Для третьего Пункта ТЗ вставляем ПК источник трафика в порт 3 нашего QSW-3470-28T-LPOE-AC и снова видим необходимые нам два тега Vlan 101 и в нем в Vlan 35.

    vlan-35-101-1024x658.png




    Смотрите так же
    Для данной линейки коммутаторов, если у вас появилась необходимость организовать динамически назначаемый Voice Vlan, вам необходимо Разрешить получение LLDP информации. Создать Voice vlan перевести порт в режим работы Trunk Проверить что на порту разрешено LLDP Указать Voice Vlan на пор...
    Vlan-translation VLAN-translation - это функция, которая позволяет преобразовать тэг VLAN пакета в новый в соответствии с требованиями. Это позволяет обмениваться данными в разных VLAN. VLAN-translation может быть использован на обоих направлениях трафика. Ниж...
    Виртуальное тестирование кабеля(VCT) на коммутаторах QSW-2850/3470/4610 Virtual Cable Tester. Функция коммутатора, благодаря которой можно провести виртуальный тест медного кабеля.  Для ввода команды, переходим в привилегированный режим. (enable ) Далее вводим команду:  ...

    К списку