Отправить запрос
    Автоматическое обновление и конфигурация коммутатора QSW-3300/3310/3750-28(TX/F)/8200(RQ)

    Отправить запрос

    Внимание! Если у вас вопрос в техническую поддержку, то вам нужно завести заявку в разделе технической поддержки

    Автоматическое обновление и конфигурация коммутатора QSW-3300/3310/3750-28(TX/F)/8200(RQ)

    Для автоматического обновления и конфигурирования коммутатора QSW-3300/3310/3750-28(TX/F)/8200(RQ) который в выводе команды show ver выдает такой вывод
    (QSW-3750-28TX-POE-AC) #
    Switch: 1
    	System Description……………………….. QSW-3750-28TX-POE-AC, Enterprise Switch System — 24 GE + 4 10GE, 8.1.1.372, Linux 3.6.5
    	Machine Type…………………………….. Enterprise Switch System — 24 GE + 4 10GE
    	Serial Number……………………………. 00069741901010054660
    	Maintenance Level………………………… A
    	Manufacturer…………………………….. 0xbc00
    	Burned In MAC Address…………………….. 00:1F:CE:0A:3B:97
    	Software Version…………………………. 8.1.1.372
    	Operating System…………………………. Linux 3.6.5
    	Network Processing Device…………………. BCM53346_A0
    


    Для автоматического обновления и конфигурирования используется опция 125 DHCP сервера и TFTP сервер, как сервер источник.
    Доступен данный функционал с ПО версии 8.1.1.328.

    Содержание TFTP

    На TFTP сервере необходимо расположить два файла и непосредственно файл ПО для обновления.

    1)run.cfg
    2)firmware.stk
    3)непосредственно файл ПО для обновления.(например qsw3750-8.1.1.361-c1b0o1.stk)

    Внутри файла run.cfg необходимо расположить типовую конфигурацию, которая будет скопирована в startup-config

    Внутри файла firmware.stk должно находится следующее содержимое

    		 /3750/qsw3750-8.1.1.361-c1b0o1.stk
    		 update bootcode
    То есть первая строчка указывает путь на TFTP сервере где находится файл ПО, а вторая указывает на необходимость обновления загрузчика.

    На этом файлы на TFTP подготовлены

    Настройка DHCP сервера

    На DHCP сервере кроме стандартных IP адреса, маски подсети, шлюза по умолчанию и DNS серверов необходимы следующие параметры
    1. Опция 66 (Next-server) — TFTP сервер откуда будет браться файл ПО, в нашем примере 10.10.254.99
    2. Опция 67(Bootfile name) —  Файл конфигурации который будет копироваться в startup-config, в нашем примере run.cfg
    3. Опция 125(Vendor-Identifying Vendor-Specific Information) — это строка в hex формате следующего вида
      00 00 6b 7a 0e 05 0c 66 69 72 6d 77 61 72 65 2e 73 74 6b
      В которой являются составляющими
      00 00 6b 7a — Enterprise ID Qtech
      0e — длина опции
      05 — сабопция
      0c — длина сабопции
      66 69 72 6d 77 61 72 65 2e 73 74 6b — Имя файла firmware.stk на TFTP сервере
    Пример настройки DHCP на unix

     subnet 10.10.254.0 netmask 255.255.255.0 {
     range 10.10.254.10 10.10.254.254;
     option routers 10.10.254.1;
     option broadcast-address 10.10.254.255;
     filename «/run.cfg»;
     next-server 10.10.254.99;
     option vivso 00:00:6b:7a:0e:05:0c:66:69:72:6d:77:61:72:65:2e:73:74:6b;
     }
    


     Пример настройки DHCP на Микротик

     /ip dhcp-server option
     add code=125 name=125 value=0x00006b7a0e050c6669726d776172652e73746b
     /ip pool
     add name=pool1 ranges=10.10.254.10-10.10.254.100
     /ip dhcp-server
     add address-pool=pool1 disabled=no interface=bridge1 name=server1
     /ip address
     add address=10.10.254.1/24 interface=bridge1 network=10.10.254.0
     /ip dhcp-server network
     add address=10.10.254.0/24 boot-file-name=run.cfg dhcp-option=125 dns-none=yes gateway=10.10.254.1 netmask=24 next-server=10.10.254.99

    Принцип работы

    1)При первой загрузке все интерфейсы коммутатора находятся в Vlan1
    2)По умолчанию на Vlan1 включен DHCP клиент.
    3)Коммутатор, получив IP адрес и необходимый набор опций обращается к TFTP серверу указанному в next-server и пытается скачать файл указанный в опции 125, в нашем случае firmware.stk, в котором указан путь до необходимого ПО.
    4) Коммутатор сверяет свое текущее ПО с ПО указанным в firmware.stk. Если ПО различается, то будет скачано и установлено для работы по умолчанию ПО указанное в firmware.stk.
    5)После того как коммутатор скачал ПО и перезагрузился идет проверка доступности файла с конфигурацией на TFTP сервере(в нашем случае run.cfg). Данный файл будет сразу записан в startup-config и после уже применен из startup-config как при обычной загрузке коммутатора.


    Смотрите так же

    К списку